You Can’t Run WhatsApp On Your Smartphone after December 31st

Do you own an older smartphone or a feature phone? If yes, then chances are that you won’t be to use WhatsApp after 31st December, 2016. Being one of the most popular messaging platform, WhatsApp is used by around 95 percent of users in India who have smartphones.

In the coming year few of those smartphone won’t be able to run WhatsApp. Even though these phones won’t be blocked permanently but they will surely lose various upcoming features of this app. This means that those who own these smartphones would only be able to use WhatsApp only if those smartphones are compatible with the app.

As per the statement released in start of this year, WhatsApp won’t have support for few of the Android, iOS, Symbian, BBOS and Windows operation system versions. WhatsApp has announced that some smartphones will no longer provided with support from 31st December, 2016 onwards. People owning these smartphones running on older version of Android, Windows and iOS along with those owning feature phones having Symbian and BBOS operating system will be the most affected ones.

The users of these smartphones could have higher risk of their WhatsApp information on these phones. Running WhatsApp on these smartphones and feature phone possess higher security risk as there won’t be any updates and security patches released by the WhatsApp development team.

As per WhatsApp announcement, following smartphones will no longer have support for WhatsApp Messenger:

1. BlackBerry along with BlackBerry 10.

2. Nokia Symbian S60 and Nokia S40.

3. Android 2.1 and 2.2..

4. iPhone 3GS or iOS 6.

5. Windows Phone 7.1.

According to WhatsApp team, the app won’t offer the upcoming capabilities that they are going to bring in the future. In case anyone us using these phones, then they should upgrade to newer version of Android, iPhone or Windows Phone by the end of 2016 in order to continue using WhatsApp.


Leave a Reply